SSW Blog

Bummer, No Success After WP 2.8 Upgrade

Posted on | June 12, 2009 | No Comments

Last night I had dared to apply the WP plugin, WordPress Automatic Upgrade and hoped that it may work once I upgraded WP from version 2.7.1 to 2.8. To my surprise, I had faced the blank white screen page except one error saying,

“Warning: require_once(ABSPATHwp-admin/includes/dashboard.php)
[function.require-once]: failed to open stream: No such file or directory in /home/(username)/public_html/wp-admin/index.php on line 13”

No idea, I had to search through the support forum or google and however,  it was suggested that I tweaked the URL in php file. After tweaking it still did not work but led to another new error.  See the error message here:

“Fatal error: require_once() [function.require]: Failed opening required                                                                                          ‘ABSPATHwp-admin/includes/dashboard.php’                                                                                                                                          (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/(username)/public_html/wp-admin/index.php on line 13″

Again no idea what the heck this error means, I had to remove all old WP files and reinstall WP 2.8 except some files that I saved for backup. Of course, I had the old database files for backup. (God blessing!) After done with reinstalling WP 2.8, I had discovered that there was an error about plugin files as I had restored plugin from my old WP files. However, I had to clean out old plugins which were not activated during the blog site and reinstall new plugins that I want for the final site. Not easy to keep old plugins but I had to ensure that some plugins are upgraded and compatible with WP 2.8.

Finally after I spent over over 8 hours of repairing WP upgrade, this blog site came out working fine with WP 2.8 but visual text editor was missing (no Visual tab on Posts).  Then I was unwilling to trust anything saying upgrade button but had swallowed my doubt by going to Tools , Upgrade and clicked “Automatic Upgrade”. (I believed that it could reinstall the package to bring all files up-to-date in order.)  No luck, the visual editor did not appear, no matter.

As I had to scan through the WP forum and found one that had suggested that we turn off the Google Gears and the visual editor would appear. I thought it was a possibility and so I went along with this suggestion. It works fine. But, but but…what about IE? No success on Posts – Visual panel but nothing was typed on the screen – white blank! I am using the Mozilla Firefox for time being since the visual and html editor work on Posts. There is one bug being unsolved!

Phew! My advice is for you who want to upgrade your WP blogs, best to wait for several weeks and don’t upgrade to WP 2.8 yet.  There will be some new and unfriendly errors. I don’t know whether I will confront some new bugs here in WP 2.8 but pray that it will not happen again. Wish me luck!